Emails delayed
Incident Report for Chainels
Resolved
This incident has been resolved.
Posted Jan 20, 2022 - 16:24 CET
Identified
A sudden unexpected spike in emails sent through our platform has caused disruptions to our email services. The emails will still arrive, but with a delay of max. 24h. We are monitoring the situation and will take measures to prevent this in the future.
Posted Jan 19, 2022 - 16:20 CET
This incident affected: Web platform.