Submitting request forms on the app is not functional

Incident Report for Chainels

Resolved

This incident has been resolved.
Posted Mar 15, 2022 - 15:11 CET

Investigating

We are working on a fix.
Posted Mar 15, 2022 - 13:55 CET
This incident affected: iOS apps and Android apps.