Delayed email notifications
Incident Report for Chainels
Resolved
This incident has been resolved.
Posted May 31, 2023 - 08:44 CEST
Identified
Currently we are experiencing slower email delivery on the platform. Emails can be delivered with several hours of delay. We are actively working on a solution. Thank you for your patience.
Posted May 30, 2023 - 15:39 CEST